Информация

Программа "Быстрый Набор 4"

Navigation: »No topics above this level«

Программа "Быстрый Набор 4"

 Return to chapter overview

Основные возможности программы:

1. Работа с любым приложением операционной системы Windows 7, Vista и XP.

2. Возможность пополнения словаря как прямым редактированием *.txt файла словаря, так и с помощью горячей клавиши во время показа специальной подсказки.

3. Интеллектуальная работа со знаками препинания.

4. Также включена звуковая клавиатура которая пригодиться людям со слабым зрение.

5. В дополнение в состав программы включена настраиваемая панель для запуска четырёх необходимых Вам программ.

6. Работа с шаблонами.


Сайт проекта

Navigation: Информация >

Сайт проекта

Return to chapter overview

Сайт проекта БН www.bnabor.ru

Ведущий программист проекта Поляков Дмитрий Владимирович почта almaz-vil@list.ru


Благодарности

Navigation: Информация >

Благодарности

 Return to chapter overview

За идею этого проекта и настойчивость в разработке:

Владимиру Бочкову.

За связь между автором идеи и мною:

Пузанову Александру.

И всем сотрудникам Web-студия Минерва.


Руководство пользователя

Navigation: »No topics above this level«

Руководство пользователя

 Return to chapter overview

Краткое знакомство с проектом "БН".

Программа “Быстрый набор” создаётся для людей с ограниченными возможностями. А также для тех у кого нет времени на обучение скоростному набору текста. Работает по тому же принципу что и поисковые системы. По мере того как человек набирает букву, тут же выпадает меню со списком всех слов, начинающих на эту букву. Остается только выбрать слово и печатать дальше.

В программе БН 2 и БН 1 есть два словаря: Русский и Английский. Имеется возможность добавлять неограниченное количество словарей, добавлять свои слова в словарь, автоматически сохранять документ, настраивать горячие клавиши, интеллектуальная работа со знаками препинания. В состав БН 2 включены две клавиатуры — звуковая и виртуальная. Программа “Быстрый набор” проста в использовании. С ней могут работать как взрослые, так и дети. Работа программы проверенна в системе XP SP2 и Vista.

На данный момент БН 3 является не отдельным приложением, а дополнением к текстовым приложениям операционной системе. На данный момент имеет в своем составе звуковую клавиатуру и настраиваемую панель быстрого запуска.

Текущая программ БН 4 является доработанной и переработанной версией БН 3.


Знакомство с БН 4

Navigation: Руководство пользователя >

Знакомство с БН 4

 Return to chapter overview

Наша программа старается облегчит общение с компьютером людям с ограничеными возможностями. А люди которые испытывают трудности с великим русским языков, могут использовать данную программу как орфографический словарь.

Рассмотрим принцип работы программы

1. После запуска программы в области рядом с часами появляется значок БН 4. Вид до запуска [image] и вид области уведомления после запуска [image] .

2. Программа может работат в режиме словаря, в режиме звуковая клавиатура и совместно сразу в двух режимах.

3. Выбирать необходимый режим можно как с помощью контекстного меню значка [image] , с помощью горячих клавиш, а также с помощью специального меню которое вызывается следующим образом. В режиме словаря перейдя к выбору слова нажмите клавишу <ALT> или <Home> и работайте с строкой меню

. Таким образом из работы с нашей программой можно исключить компьютерную мышь.

4. Для включения режима словаря. Нажмите клавишу <F8> данная клавиша определена по умолчанию! При включенном режиме, после начала ввода текста появляется список из 7 или 8 слов. (см. рис. )

Для перехода к словарю. Нажмите клавишу <DOWN> - курсорная клавиша вниз. С помощью курсорных клавиш выделите нужное слово.

И нажмите клавишу <ENTER>, программа вставляет выделенное вами слово и добавляет пробел после него. При этом список слов исчезает.

Также возможно после появления списка нажат клавишу с цифрой от 0 до 8 обычно и слово из списка напротив которого находилось вводимая цифра вставляется в текст. Этот метод даже там где выше описанный способ не работает. Это к примеру: ввод при переименование файлов.

5. Шаблоны.

Нужный шаблон вставляется из специального файла после набора определённого сокращения.

6. Особым образом также происходит реакция на различные знаки препинания.
На данный момент программа разделяет знаки препинания на пять групп:

В первую группу входят следующие знаки: (.!?)- программа автоматически ставит пробел после соответствующего знаков, делает заглавной введенную за ними букву, и при наличие до знака пробела удаляет соответствующей пробел.

Вторая группа - (,:;) - после знака добавляется пробел, и при наличие до знака пробела удаляет соответствующей пробел.

Третья группа - ( - + = ) - после знака добавляется пробел, до знака также добавляется пробел при его отсутствии.

Четвертая группа - ( { [ ( <) - после знака пробел удаляется, а до знака добавляется пробел при его отсутствии.

Пятая группа - (>}]) - после знака добавляется пробел, а до знака удаляется.

При необходимости добавит новое для программы слово в словарь, можно при появление специальной подсказки нажмите клавишу <F5>. По умолчанию назначена именно она.

Особо следует рассмотреть работу с горячими клавишами программы, так как они перекрывают работу горячих клавиш остальных приложений. Следует особо отметит тот факт, что в настройках БН 4 возможно изменит практически любую горячую клавишу.

По умолчанию я выбрал следующие горячие клавиши: Рассмотрим их подробнее.

Клавиша <F5> активизируется при появление специальной подсказки [image] и с исчезновением данной подсказки клавиша прекращает своё действие.

Клавиша <стрелка вниз> активизируется при появлении списка слов и со скрытием данного прекращает своё действие.

Клавиша <ESC> активизукется после перехода к словарю и следовательно прекращает свое действие при сокрытие списка слов.

Клавиша <F4> активизируется при запуске программы и прекращает своё при выходе из БН 4. Служит для активизации и деактивации остальных горячих клавиш, что минимизирует возможность конфликта с горячеми клавишами другого приложения.

После активации клавиша <F8> включает или выключает режим словаря, клавиша <F2> включает или выключает режим звуковой клавиатуры, и клавиша <Page Down> включает или выключает отображение панели быстрого запуска. Настройка панели осуществляется в настройках программы.

После активации клавиша <F9> служит для выхода из приложения "Быстрый Набор 4".

В техническом разделе будет рассмотрена настройка программы.


Редактор словарей

Navigation: Руководство пользователя >

Редактор словарей

Return to chapter overview

Замечание: в текущей версии программы добавлен режем "Специальный" который позволяет с помощью словаря производить ввод целых словосочетаний с различными знаками препинания. Переключится в данный режим и соответственно выйти из него, можно через контекстное или главное меню, а также "горячей" клавишью. Отмечу, что в данном режим сброс накопленного ввода происходит после нажатия клавиши enter или же введите <пробел> и <->. Накопленный ввод можно оперативно добавить введя <пробел> и <->.

В связи с вводом в строй возможности работы с неограниченным числом словарей, изменился формат хранения данных о словарях. В случае если программа обнаружет в папке "словари" файл config.ini то она считав с него информацию заменяет на Newconfig.ini

Главное окно редактора словарей:

В программе определены пять групп словарей, дадим этим группам характеристику:

Русский - программа обращается к нему при вводе кириллицы.

Английский - программа обращается к нему при вводе латиницы.

Шаблоны - программа обращается к нему при вводе определеных в нём специальных ссокращений и выводит соответствовавшие им словосочетания.

Специальный - программа обращается к нему при работе в "Специальном" режиме. смотри примечание выше.

Употребляемые - программа обращается к нему при вводе кириллицы и латиницы и автоматически добавляет в него выбираемые слова из словарей групп "Русский" и "Английский".

Отметим, что в четыре группы (Русский, Английский, Шаблоны, Специальный) можно добавлять неограниченное число словарей, а программа использует лишь один, активный, словарь из группы. Имейте в ввиду в одной группе не может быть более одного активного словаря. В пятой группе (Употребляемые) добавление словарей невозможно.

При выделение словаря в списке, происходит его загрузка следует отметит, что для больших словарей этот процесс может занять значительное время, при необходимости нажмите <Esc> или же кнопку "стоп" в этом случае просто с экономите время, а в функциональном плане ни чего не измениться.

Для визуального определения каждая из групп словарей имеет свой цвет, а активные в группе словари обозначены значком "(А)". Для каждой из четырёх групп вы можете задать свой цвет [image] щёлкните на необходимый прямоугольник и выберите цвет.

Активность словарей выставляйте с помощью фишек

Познакомимся с возможными операциями над словарями.

- создание нового файла-словаря [image] , а затем задаётся имя и группу создаваемого словаря [image] .

- добавление файла-словаря, анологично созданию файла-словаря, за тем исключением, что файл-словаря уже был создан. Отметим если файл-словаря при открытие находился в не папки "... /словари/", то он туда копируется автоматически.

- даёт возможность задать новое имя для выделенного в списке словаря.

- позволяет удалить из списка выделенный словарь и, ВНИМАНИЕ! его файл с диска.

- активизируется при любом изменении списка словарей которое требует сохранения, после сохранения становится неактивной.

Отметим, что любую реакцию операцию можно выполнить с помощью строки меню.

С элементами выделенного словаря в списке, возможно выполнить ниже следующие операции:

- добавляет в словарь содержание верхней строки ввода. В данном случае это строка "Достоевский Фёдор Михайлович"

- удаляет из словаря выделенную строку в данной ситуации это строка "Александр Сергеевич Пушкин".

- изменяет выделенную строку в текущем словаре на содержание нижний строки ввода.

- сохраняет произведенные изменения в текущем словаре.

Также возможна добавить несколько словарей определённой группы, через меню "Словари - Добавить".


Технический раздел

Navigation: Руководство пользователя >

Технический раздел

 Return to chapter overview

На странице "Настройка" рассмотрены принципы изменения внешнего облика списка слов.

Подбор приложений для запуска через Панель БН 4. И возможность выбора горячих клавиш.

На странице "Файлы БН 4" приводятся некоторые сведения о внутреннем строении программы.


Настройка

Navigation: Руководство пользователя > Технический раздел >

Настройка

 Return to chapter overview

По команде контекстного меню программы "Настройка" появиться окно:

На вкладке "Визуальное оформление" можно подобрать необходимый Вам цвет фона списка, цвет и размер шрифта слов в списке. По умолчанию выбран шрифт " New Roman" при желании его можно изменить прямым редактированием файла configP.ini структура которого рассмотрена в разделе "Файлы БН 4".

Кратко опишем значение флажков:

Флажок | Состояние | описание | пример
Словарь в окне | вкл | Список слов появляется в окне |
 | выкл | Просто список слов |
Звук при отсутствие слова | вкл | Если слово не найдено в словаре подаётся звуковой сигнал |
 | выкл | И не подается соответственно |
Отображать справочное окно | вкл | При запуске программы будет отображаться |
 | выкл | И не будет отображаться соответственно |
Визуальный шаблон | вкл | После ввода специального сокращения ранее оопределённый шаблон |
 | выкл | После ввода специального сокращения появляется список с шаблонами для выбора путем перехода к словарю и нажатием клавиши <Enter> |

На вкладке "Панель управления" можно изменить надпись на кнопке и выбрать файл который будет запускаться по щелчку на соответствующей кнопке.

При желание возможно отредактировать файл configPanel.ini отметим, что запускаются только программные файлы, то есть с расширением *.exe.

На вкладке "Горячии клавиши" возможно подобрать удобную для Вас клавишу клавиатуры для каждой из предложенных операций.

ВНИМАНИЕ!!! Выбор одной клавиши для более чем одной операции приведёт к неработоспособности программы БН 4!!!
Путём прямого редактирования файла vk.ini можно увеличит число предлагаемых клавиатурных клавиш. А в файле configP.ini произвести ручной ввод горячий клавиши для каждой операции..


Файлы БН 4

Navigation: Руководство пользователя > Технический раздел >

Файлы БН 4

 Return to chapter overview

После работы установочного файла программы. В папке БН 4 Вы найдёте в том числе следующие файлы.

1. Файл configP.ini который содержит основные параметры программы.
Рассмотрим его структуру:
[Color] // цвет в цифровой форме

Fon=65535 // для фона в списке слов

Text=8 // и для текста соответственно

[Font] // параметры для шрифта в списке слов

FontName=Times New Roman // имя шрифта

FontSize=22 // размер шрифта

[Flagi] // режимы работы программы 0 - выключен 1 - включен

SoundKLAVA=0 // звуковая клавиатура (выключена)

Panel=0 // панель (выключена)

flagClovar=1 // словарь (включен)

[Position_Panel] // позиция панели в экранных координатах

Top=30 // по Y

Left=262 // по Х

[TekGoriachiiKlavishi] // определение текущих горячих клавиш значения определённы в файл vk.ini (смтр. ниже)

VKAddClovo=116 . // добавить новое слово

VKInClovar=40 // перейти к выбору слов

VKNotClovar=27 // выйти из словаря и отказаться от выбора слова

VKClovo=13 // подтвердит выбор слова

VKOnOffClovar=119 // включить/выключить словарь

VKOnOffSoundKlava=113 // включить/выключить звуковая клавиатура

VKOnOffVk=115 // включить/выключить горячии клавиши

VKOnOffPanel=34 // включить/выключить панель

VKOffBN3=120 // выключить программу.

2. Файл vk.ini который содержит список виртуальных клавиш. При желание может дополняться формат строк [наименование клавиши]=[её код]

Текущее содержание файла:

ENTER=13

Стрелка вверх=38

Стрелка вниз=40

Стрелка вправо=39

Стрелка влево=37

Home=36

End=35

Page Down=34

Page Up=33

ESC=27

F1=112

F2=113

F3=114

F4=115

F5=116

F6=117

F7=118

F8=119

F9=120

F10=121

F11=122

F12=123

3. Файл configPanel.ini который содержит параметры для Панели БН 3.

Структура файла:

[ButtonRUN]

CaptionB1=Быстрый набор //надпись соответствующей кнопки

RUNB1=Bn2.exe // полный путь к запускаемому файлу

CaptionB2=Виртуальные клавиши

RUNB2=

CaptionB3=Говорящие клавиши

RUNB3=

CaptionB4=MS Word

RUNB4=C:\Program Files\Microsoft Office\Office10\WINWORD.EXE

Для работы звуковой клавиатуры необходима папка "ЗВУКИ" содержавшия wav файлы.

В папки "СЛОВАРИ" содержится обычный текстовой файл со списком слов и файл config.ini со списком словарей.
Его структура:

0|английский|словари\en.txt|2| - список содержащий английские слова.

1|русский|словари\RUS.txt|1| - список содержащие русские слова.

2|выборка|словари\rusdop.txt|3| - специальный список часто употребляемых слов с автоматическим добавлением. Иными словами формируется во время работы.

3|шаблоны|словари\shablon.txt|4| - список определённого формата строк.

Формат строк в списке шаблонов:

специальное сокращение = вставляемая строка

К примеру:
а2=almaz-vil@mail.kamchatka.ru

б8=для ознакомления

р9=Мой сайт "Мой Рыбачий" по адресу www.pibachii.narod.ru

а9=Мой сайт "Мой Рыбачий" по адресу www.p-k-53.ru Приходиите!

ак9=Автомат Калашиникова!

я1=Поляков Дмитрий Владимирович

друг1=Калюжный Борис Владимирович

кинига1="Тихий Дон" Михаила Шолохова

Важно: Специальное сокращение начинается с и содержит лишь буквы русского и английского алфавита любого регистра, но заканчивается лишь цифрой (0, 1, 2, 3, 4, 5, 6, 7, 8, 9). За специальным сокращением идёт знак = и за ним любая строка. Желательно соблюдать следующее правило "Не использовать символы английского и русского языка в одной шаблонной строке", но возможно и разумное сочетание знаков английского и русского языка как в примере и русской раскладке.


К пользователю.

Navigation: »No topics above this level«

К пользователю.

Return to chapter overview

Наша программа БЫСТРЫЙ Набор 4, является бесплатным программным обеспечением.

Если вам понравилось то, что мы делаем, можете поддержать наш проект материально. Для дальнейшего - развития и существования.

Наш счёт в Яндекс.Деньги: 41001717624568

Если Вам удобен другой способ оплаты или Вы желаете помочь нам иным образом (оплатить хостинг) свяжитесь с нами по адресу: prog@bnabor.ru и almaz-vil@list.ru