О Программе.

Следующая

Краткое описание программы DVKlava:

Программа DVKlava поможет вам работать с текстом быстрее и аккуратнее и намного эффективнее, чем на стандартной экранной клавиатуре Windows и аналогичных программах.

DVKlava является набором экранных клавиатур и Визуальным Конструктором, для создания любых экранных клавиатур, любого вида и назначения, в одной программной оболочке.

И предоставляет возможность использовать виртуальную экранную клавиатуру, когда нет возможности использовать обычную клавиатуру. Или стать для Вас заменителем экранной клавиатуры в Windows.

При этом за счет встроенных дополнительных функций программа помогает печатать текст быстрее, чем на обычной клавиатуре. И не только печатать, а самое главное быстро выполнять часто повторяющиеся действия: запускать программы, открывать веб-страницы, а делать также вставку знаков препинания, цифр и букв, любых сочетаний клавиш в созданной вами клавиатуре, в одно касание.

А также вы сможете вставлять пароли и логины для ваших любимых сайтов без риска их перехвата программами шпионами!

Все эти действия вы сможете назначить разным шаблонам клавиатур для разных программ и любых потребностей вашей работы с вашим компьютером.

В поставке DVKlava идет около 5-6 различных видов экранных клавиатур для работы в самых популярных программах или в качестве образцов.

Не нашли клавиатуру, которая устраивает вас? Измените любую из имеющихся клавиатур или создайте вашу собственную с помощью встроенного редактора. Настройте цвет, шрифт, формы кнопок, вид самой клавиатуры и прочие параметры на ваш вкус.

Ограничений нет! Только ваша фантазия и способности и потребности облегчить работу!

В поставке программы имеется пока 5-6 видов клавиатур.

Но вы можете заказать нам на нашем сайте любую экранную клавиатуру очень недорого.

С помощью DVKlava вы можете настраивать клавиши ваших клавиатур на выполнение частых и постоянно нужных действий: вставка текста, его копирование и вырезание в любом текстовом редакторе и в любые поля ввода.

Для пользователей с ограничениями по здоровью добавлена возможность управлять самой программой и самими клавиатурами, так с помощью мыши, так с помощью горячих клавиш, обычной клавиатуры, все это настраиваются в настройках программы.

Можно:

скрывать/отображать, перемещать, все окна и вкладки в конструкторе, и кнопки на форме конструируемой клавиатуры в режиме Конструктора.


Окно «Настройка».

Наверх Предыдущая Следующая

Наша программа имеет окно настройки:

Напоминаю, что практически все списки выбора клавиш в нашей программе действуют по следующему принципу:

•

Нажмите клавишу <Стрелка вниз >, список открывается;

•

Нажимая, клавиши <Стрелка вниз > и <Стрелка вверх > выбираем необходимую клавишу;

•

Для подтверждения выбора нажмите <Enter> и список закроется.

Клавиша <Tab> служит для перемещения фокуса между элементами окна.

Отключить полностью все глобальные горячие клавиши нашего приложения можно из контекстного меню значка приложения, возле часов:

Из контекстного меню так можно:

•

Вызвать окно настроек;

•

Вызвать окно конструктора;

•

Показать \ скрыть виртуальную клавиатуру;

•

Отключить \ включить глобальные горячие клавиши приложения;

•

Показать справку:

•

Закрыть приложение полностью.


Окно «Конструктор Виртуальной клавиатуры».

Познакомимся теперь с основным окном конструктора.

Начнём знакомство сверху вниз.

Строка расположенная ниже заголовка окна:

Содержит выпадающий список основных и созданных Вами клавиатур, нажмите клавишу <стрелка вниз> и список откроется.

, после выбора необходимой клавиатуры происходит её загрузка в режиме конструктора. Выбор осуществляется как щелчком мыши, так и нажатием клавиши <ENTER>.

Если ввести в поле списка название не существующей клавиатуры и нажать кнопку « Создать клавиатуру (F7)»,то будет создана новая клавиатура на основе текущей.

Обратите внимание,что бы перейти к списку клавиатур, можно нажать клавишу <F10>. А чтобы создать новую клавиатуру,надо нажать клавишу <F7> соответственно.

Познакомимся теперь с панелью кнопок-вкладок слева:

На ней мы видим четыре основных вкладки:

•

Кнопки ВК (F4) – вкладка используется чаще всего. Служит для управления основными объектами виртуальной клавиатуры – кнопками в частности:

o

Местоположение;

o

Размер;

o

Местоположение кнопок относительно друг друга;

o

Выбор шаблона оформления как для одной кнопки, так и для множества кнопок.

•

Шаблоны кнопок (F2) – вкладка используется для создания новых шаблонов оформления кнопок ВК.

•

Шаблоны формы (F3) – вкладка служит, для визуального оформления основы ВК, на которой расположены кнопки. А в частности это:

o

Размер формы ВК;

o

Выбор шаблона оформления из библиотеки форм;

o

Создания новых шаблонов оформления клавиатур.

•

Новая кнопка (F5) – вкладка используется для пополнения виртуальной клавиатуры новыми кнопками. Служить для создания дополнительных кнопок трёх типов действия, в частности это:

o

Записки - текст, отображаемый на кнопке,который просто вводиться в нужное вам место. Это может быть номер телефона, пароль, адрес, да и просто всё,что угодно. В отличие, от аналогов это записки ни нужно копировать и вставлять.

o

Запуск - кнопки ярлыки, вводишь любой текст на кнопке, выбираешь любой файл, который нужно открыть или запустить и всё. Избавляет от иногда не реального поиска нужного ярлыка на рабочем столе и в меню пуск. Поможет создавать архивы файлов.

o

Комбинация -комбинации клавиш и \ или их сочетания. Одной кнопкой заменяется нажатия сочетания клавиш, они станут ещё удобнее, если вы добавите поясняющий текст прямо на кнопке. Например: Кнопка "Копировать" - заменить сочетание Ctril+C,любые другие сочетания клавиш,а также для поисков в меню окна нужного действия.

Рассматриваемая панель также содержит две кнопки это:

•

Кнопка « Справка (F1) » служит для вызова данной справки.

•

Кнопка « Сохранить (F12)» используется для сохранения текущей клавиатуры. При ее нажатии надпись на кнопке изменяется на сообщение «Сохраняю...», и при этом происходит сам процесс сохранения всех изменений. По окончанию процесса сохранения надпись на кнопке примет прежний вид « Сохранить (F12)».При этом делается снимок-скриншот текущего вида клавиатуры,который копируется в папку Virtual,где сохраняются все шаблоны клавиатур.

Щелчок по открытой кнопке-вкладке скрывает её. Скрывать вкладки необходимо, чтобы они ни мешали друг другу, и чтобы хватило функциональных клавиш для управления нашим Конструктором.

И последний объект, расположенный на рассматриваемой нами панели вкладок-это список активных кнопок, то есть он содержит те кнопки или кнопку, для которых можно задавать различные параметры на вкладке «Кнопки ВК (F4)».

Окно Конструктора также содержит строку состояния:

В строку выводятся краткие подсказки. Сообщается клавиша клавиатуры, которая нажималась пользователем последней.


Вкладка «Шаблоны формы (F3)».

Познакомимся теперь с самой основой виртуальной клавиатуры – с видом формы, на которой и располагаются кнопки. Для начала закроем вкладку « Кнопки ВК (F4)» и откроем вкладку « Шаблоны формы (F3)».

После успешного открытия, мы наблюдаем следующую картину:

Слева расположен активный шаблон визуального оформления формы, который можно изменят по Вашему желанию, после настройки шаблон можно сохранить в библиотеке форм, кнопкой «(Insert)>>».

Справа располагается библиотека визуальных шаблонов оформления формы. Понравившийся шаблон выбираем щелчком мыши.

Обращаю внимание, что для просмотра библиотеки можно пользоваться клавишами:

•

<Page Up> для постепенного перемещения к началу;

•

<Page Down> для перемещения к концу библиотеки.

Чтобы выбрать шаблон оформления с помощью клавиатуры следует нажать клавишу <F12> и выбрать из списка необходимый шаблон.

Кнопка

применяет активный шаблон оформления к форме ВК. Данная операция возможна также, если нажать клавишу <Home>».

Для изменения активного шаблона оформления служить нижняя часть вкладки:

Единицами измерения являются экранные пиксели, учтите если Высота и Ширина превышает ваше экранное расширение, то ВК займет весь экран.

Ширина линии бордюра (границы) формы обычно изменяется в пределах от 0 до 20, если она больше Высоты или Ширины формы, то результат может Вас не обрадовать.

Например:

Ширина линии бордюра равна четырем и он зеленый.

А вот пример со смещением тени текста.

Тут значение равно «13»:

А тут значение равно «-13»:

Кнопка « Стиль (F10)» служить для выбора стиля градиента который используется для заливки формы. После нажатия данной кнопки Вам будет предложен выбор, в данном примере он выглядит так:

Выбор необходимого стиля градиента осуществляется щелчком мыши по нужному стилю, или же с помощью клавиатуры, вводим номер способа заливки и нажимаем <ENTER> .

Ниже расположена таблица клавиш.

Клавиша | Операция
Home | Применяется визуальный шаблон к форме
Insert | Добавляет активный шаблон в библиотеку
Page Up | Для постепенного перемещения к началу библиотеки визуальных шаблонов
Page Down | Для перемещения к концу библиотеки визуальных шаблонов
F3 | Открытие\закрытие вкладки « Шаблоны форм »
F4 | Вызов диалога выбора цвета для первого цвета градиента
F5 | Вызов диалога выбора цвета для второго цвета градиента
F7 | Вызов диалога выбора цвета для тени текста
F8 | Вызов диалога выбора цвета для бордюра (границы) формы
F9 | Вызов диалога выбора цвета для цвета текста
F10 | Вызов диалога выбора стиля градиента (заливки)
F11 | Вызов диалога выбора шрифта
F12 | Активация списка выбора визуального шаблона из библиотеки


Вкладка «Кнопки ВК (F4)».

Рассмотрим вкладку «Кнопки ВК (F4)» которая открывается при запуске Констриктора виртуальных клавиатур.

Предлагаю Вам щёлкнуть по кнопке «Библиотека кнопок (F2)» или же нажать клавишу <F2> для загрузки библиотеки визуальных шаблонов кнопок.

Обратите внимание для открытия вкладки «Шаблоны (F2)» также используется клавиша <F2>, но перед открытием данной вкладки следует скрыть текущую вкладку «Кнопки ВК (F4)» нажав соответственно клавишу <F4>!

После загрузки библиотеки, вкладка принимает более полный вид:

Важнейшим элементом данной вкладки, да и, пожалуй, всего конструктора является список кнопок ВК.

Рассмотрим его структуру:

Любая кнопка имеет определённый формат строки обозначения в списке кнопок.

В частности все кнопки имеют уникальный номер для клавиши "8" это 56; для клавиши "э" это 253 соответственно. Далее идёт или же надпись, которая отображается на кнопке виртуальной клавиатуры, или же два символа разделенным пробелом первый символ отобразится при английской раскладке, а второй соответственно при русской раскладке. Уникальный номер для кнопок стандартной клавиатуры, является номером соответствующей виртуальной клавиши для клавиатуры. Уникальный номер для пользовательских кнопок, является просто опознавателем для сохранения настроек.

Если обратит своё внимание на панель ВК появившуюся с окном конструктора. То на нём с помощью мыши можно выделить нужную кнопку, которая тут же выбирается и в списке "Все кнопки ВК (F11 к списку)" в окне "Конструктор виртуальной клавиатуры", и становиться активной, то есть помещается в список на левой панели окна.

Например:

Мы выбрали кнопку с цифрой «8», предлагаю познакомиться с доступными панелями в текущей ситуации на вкладке.

Панель « Положение (F7)» содержит поля:

•

Справа значение, которого равно расстоянию от левой границы формы до левой границы кнопки «8»;

•

Сверху – расстояние от верхней границы формы до верхней границы кнопки.

Панель « Размер (F5)» содержит поля:

•

Ширина – расстояние от левой границы кнопки до правой границы кнопки;

•

Высота – расстояние от верхней границы кнопки до нижней границы кнопки.

Покажем это схематично на примере нашей виртуальной клавиатуры.

Для активной кнопки (или группы кнопок смотри ниже),надо просто выбрать визуальное оформление.

Это можно сделать с помощью щелчка мыши по понравившемуся шаблону из библиотеки: кнопок

Обращаю внимание, что для просмотра библиотеки можно пользоваться клавишами:

•

<Page Up> для постепенного перемещения к началу;

•

<Page Down> для перемещения к концу библиотеки.

Чтобы выбрать шаблон оформления с помощью клавиатуры обратите внимание на панель « Выбор шаблона (F8)»:

В списке выбираем номер шаблона, просто нажимая курсорные клавиши <Стрелка вниз> и <Стрелка вверх>.

После выбора нажмите клавишу <ENTER>, чтоб применить шаблон к кнопке или группе кнопок.

Если установлен флажок « Не учитывать размер »,то к кнопке будет применяться только графическое оформление шаблона без учета его размеров.

Освоим теперь работу с целой группой кнопок.

Для начала следует поставить флажок « Множественный выбор (F3)».

После того как флажок будет поставлен,то список активных кнопок очищается.

Для его заполнения можно производить щелчок мыши по кнопкам виртуальной клавиатуры.

Или же воспользуемся возможностями списка « Все кнопки ВК (F11 к списку)».

С помощью клавиш <Стрелка вниз> <Стрелка вверх> выбираем нужную кнопку и нажав клавишу <Стрелка вправо> выделенная кнопка-строка добавиться в активные кнопки, клавиша <Стрелка влево> напротив удаляет кнопку-строку из списка активных.

.

Выделять, а, следовательно, и добавлять\удалять можно сразу несколько кнопок-строк. Для выбора нескольких строк используйте клавиши <Стрелка вниз> <Стрелка вверх> вместе с клавишей <SHIFT>, нажав клавишу <Стрелка вправо> выделенные кнопки-строки добавятся в активные, клавиша <Стрелка влево> напротив удаляет кнопки-строки из списка активных кнопок.

Визуальное оформление для группы кнопок задаётся также как и для одной кнопки (смотр. выше).

Группу кнопок можно выравнивать по вертикали и по горизонтали, а также задавать промежутки между выровненными объектами-кнопками.

Для этих целей служить вот эта панель.

.

Выравнивание происходить всегда относительно первой кнопки-строки в списке активных кнопок.

Например:

Кнопки выровнены относительно кнопки «1» с отступом нуль.

А тут отступ уже равен трем:

С помощью панели « Положение (F7)» или курсором мыши на самой клавиатуре-шаблоне можно изменит положение кнопки «1».

Вот, пожалуй, и всё,что касается работы с кнопками ВК..

Ниже расположена таблица клавиш.

Клавиша | Операция
END | Вызов стандартного расширенного мню окна
F10 | Переход к списку виртуальных клавиатур
F7 | Создание новой виртуальной клавиатуры
F4 | Открытие\закрытие вкладки «Кнопки ВК»
F2 | Открытие\закрытие вкладки «Шаблоны»
F3 | Открытие\закрытие вкладки «Шаблоны форм»
F5 | Открытие\закрытие вкладки «Новая кнопка»
F1 | Открывает справку
F12 | Сохраняет текущую виртуальную клавиатуру
При открытой вкладке «Кнопки ВК (F4)»
F11 | Переход к списку «Все кнопки ВК»
F3 | Включение\отключение множественного выбора
F7 | Переход к панели «Положение»
F5 | Переход к панели «Размер»
F8 | Переход к панели «Выбор шаблона»
F2 | Загрузка библиотеки шаблонов для кнопок
F6 | Применяет параметры выравнивания к группе активных кнопок ВК
Page Up | Для постепенного перемещения к началу библиотеки визуальных шаблонов
Page Down | Перемещения к концу библиотеки визуальных шаблонов


Вкладка «Шаблоны кнопок (F2)».

Познакомимся подробнее с вкладкой « Шаблоны (F2)» и с процессом создания визуальных шаблонов для кнопок.

Вид нашей вкладки:

Процесс создания похож на процесс создания визуальных шаблонов для форм, но в отличие от формы, кнопка может находиться в трёх состояниях (ожидание, наведение и нажатие) следовательно, каждая кнопка имеет три простых визуальных шаблона оформления-состояния.

Чтобы иметь возможность редактировать каждое из этих простых состояний, его следует предварительно выделить с помощью установления соответствующего флажка на панели « Оформление кнопки при:»:

Для всех трёх простых состояний, общими свойствами являются:

•

Ширина;

•

Высота;

•

Шрифт.

А вот остальные шесть изменяются в зависимости от текущего состояния шаблона кнопки.

Определены десять параметров, которые являются уникальными для каждого из трёх состояний.

Рассмотрим их:

1.Ширина линии бордюра - это другими словами толщина границы объекта.

Взгляните;

- тут у кнопки "ж" ширина линии бордюра равна "1", а тут

равна "5",

тут равна- 0

Не стоит "ширину линии бордюра" задавать более высоты (ширины) объекта!

2.Смещение тени текста - может принимать как положительные значения так и отрицательные.

Взгляните;

- тут тень "0", то есть тени нет!

- тут тень "6", видим она уходить вниз и влево при положительных значениях.

- тут уже тень "-6", видим она уходить вверх и вправо.

3. Высота дуги.

4. Ширина дуги.

Значение данных величин положительные от 0 до высоты и ширины объекта соответственно.

Взгляните;

- тут значения минимальные "0" наблюдаем квадрат.

- тут значения максимальные, в нашем примере "30", наблюдаем круг.

- тут высота дуги "15", а ширина дуги "10".

Остальные шесть параметров это цвета.

Первый цвет градиента, он также является основным и при отсутствии градиента, будет являться цветом объекта.

Нажав кнопку "Стиль (F10) > > "

можно выбрать нужный вариант градиента.

После того как шаблон сформирован можно его сохранить в библиотеке с помощью кнопки:

Так он сразу появиться в библиотеке визуальных шаблонов оформления на панели « Кнопки ВК (F7)» .

Таблица.

Клавиша | Операция
Num0 | Выбор визуального оформления для состояния « Ожидание »
Num1 | Выбор визуального оформления для состояния « Наведение »
Num2 | Выбор визуального оформления для состояния « Нажатие »
Home | Активация списка выбора визуального шаблона из библиотеки
Insert | Добавляет активный шаблон в библиотеку
Page Up | Для постепенного перемещения к началу библиотеки визуальных шаблонов
Page Down | Перемещения к концу библиотеки визуальных шаблонов
F2 | Открытие\закрытие вкладки « Шаблоны кнопок »
F4 | Вызов диалога выбора цвета для первого цвета градиента
F5 | Вызов диалога выбора цвета для второго цвета градиента
F6 | Вызов диалога выбора цвета для цвета за границами не прямоугольной кнопки
F7 | Вызов диалога выбора цвета для тени текста
F8 | Вызов диалога выбора цвета для бордюра (границы) кнопки
F9 | Вызов диалога выбора цвета для цвета текста
F10 | Вызов диалога выбора стиля градиента (заливки)
F11 | Вызов диалога выбора шрифта
F2 | Открытие\закрытие вкладки « Шаблоны »


Действия кнопок.Вкладка «Новая кнопка (F5)».

Вкладка « Новая кнопка (F5)».

Наверх Предыдущая Следующая

Рассмотрим вкладку «Новая кнопка (F5)» и познакомимся с процессом создания новых кнопок, действий или событий для новых кнопок,для нашей визуальной клавиатуры.

Внешний вид рассматриваемой вкладки:

Мы готовы Вам предложить создание не ограниченного числа дополнительных кнопок трёх типов действия, в частности это:

1.Записки - текст введенный и отображенный на кнопке данного типа,который просто вводиться в нужное вам место, это может быть номер телефона, пароль, адрес, да и просто всё,что угодно. В отличие от аналогов эти записки не нужно копировать и вставлять.

2.Запуск - кнопки ярлыки, вводите любой текст, выбираете любой файл, который нужно открыть или запустить и всё. Избавляет от иногда не реального поиска нужного ярлыка на рабочем столе и в меню пуск или на панели задач.Везде где нужно-удобно и быстро.

3. Комбинация клавиш- одной кнопкой заменяется нажатия сочетания клавиш, они станут ещё удобнее, если вы добавите поясняющий текст. Например: Кнопка "Копировать" - заменить сочетание Ctril+C, а также поисков в меню окна нужного действия.

Рассмотрим их создание.

1. Для создания кнопки вида "Записки" вводим нужный текст в строку содержащую текст "Кнопка!". И нажимаем кнопку "Добавить новую кнопку (F6)".

На пример была создана кнопка "Александр Пушкин".

2. Для создания кнопки вида "Запуск" вводим нужный текст в строку содержащую текст "Кнопка!". Производим выбор файла, нажав кнопку « Выбор файла (F7) ...» , открывается диалог выбора файла.

Выбираем нужный файл. И нажимаем кнопку "Добавить новую кнопку (F6)"

Например, была создана кнопка "Баланс 2009 НИОКОР".

3. Для создания кнопки вида "Комбинация" вводим также нужный текст в строку:

.

Ставим, галочки возле тех клавиш, которые будут нажиматься и в соответствующей последовательности.

И нажимаем кнопку "Добавить новую кнопку (F6)".

Например, создаём кнопку выделения всего текста Ctril +A

Можно галочки не ставить, а сформировать результирующую строку с помощью списка.

Чтобы сформировать результирующую строку с помощью списка. Нажмите клавишу <F9> для перехода к списку. Нажмите клавишу <Стрелка вниз >, список откроется:

Нажимая, клавиши <Стрелка вниз > и <Стрелка вверх > выбираем необходимую клавишу и для добавления выбранной клавиши в результирующую строку нажимаем клавишу <Стрелка влево>, при наличии данной клавиши в результирующей строке она напротив удаляется из строки. После того как строка сформирована можно нажать клавишу < F6> для создания кнопки.

Клавиша | Операция
F8 | Переход к строке с именем кнопки
F9 | Переход к списку клавиш для формирования результирующей строки
F7 | Вызов диалога выбора файла
F6 | Создает новую кнопку
F5 | Открытие\закрытие вкладки « Новая кнопка »


Клавиатурный интерфейс.

В нашей программе и отдельно в ее Конструкторе для создания виртуальных клавиатур предусмотрен специальный интерфейс для управления всеми ее функциями и операциями только с клавиатуры, т. е. без мыши.Все дублируется горячими клавишами.

Это ускоряет работу и делает все операции с программой и с ее Конструктором более четкими и точными.А также очень пригодится людям с болезнями рук и пальцев.

Если Вы планируете управлять Конструктором с помощью горячих клавиш только в самом Конструкторе,то мы настоятельно рекомендуем отключить на время работы с Конструктором, горячие клавиши самой программы, иначе возможно перекрытие клавиатурного интерфейса Конструктора, глобальными горячими клавишами нашей программы или других программ. Как только вы закроете окно Конструктора,то общие для всей программы, горячие клавиши включаться самостоятельно,если конечно, они были включены.

Сводная таблица всех горячих клавиш программы.

Клавиша | Операция
F10 | Переход к списку виртуальных клавиатур
F7 | Создание новой виртуальной клавиатуры
F4 | Открытие\закрытие вкладки « Кнопки ВК »
F2 | Открытие\закрытие вкладки « Шаблоны »
F3 | Открытие\закрытие вкладки « Шаблоны форм »
F5 | Открытие\закрытие вкладки « Новая кнопка »
F1 | Открывает данную справку
F12 | Сохраняет текущую виртуальную клавиатуру
При открытой вкладке « Кнопки ВК (F4) »
F11 | Переход к списку « Все кнопки ВК »
F3 | Включение\отключение множественного выбора
F7 | Переход к панели « Положение »
F5 | Переход к панели « Размер »
F8 | Переход к панели « Выбор шаблона »
F2 | Загрузка библиотеки шаблонов для кнопок
F6 | Применяет параметры выравнивания к группе активных кнопок ВК
Page Up | Для постепенного перемещения к началу библиотеки визуальных шаблонов
Page Down | Перемещения к концу библиотеки визуальных шаблонов
При открытой вкладке « Шаблоны форм (F3) »
Home | Применяется визуальный шаблон к форме
Insert | Добавляет активный шаблон в библиотеку
Page Up | Для постепенного перемещения к началу библиотеки визуальных шаблонов
Page Down | Перемещения к концу библиотеки визуальных шаблонов
F3 | Открытие\закрытие вкладки «Шаблоны форм»
F4 | Вызов диалога выбора цвета для первого цвета градиента
F5 | Вызов диалога выбора цвета для второго цвета градиента
F7 | Вызов диалога выбора цвета для тени текста
F8 | Вызов диалога выбора цвета для бордюра (границы) формы
F9 | Вызов диалога выбора цвета для цвета текста
F10 | Вызов диалога выбора стиля градиента (заливки)
F11 | Вызов диалога выбора шрифта
F12 | Активация списка выбора визуального шаблона из библиотеки
При открытой вкладке «Шаблоны кнопок (F2)»
Num0 | Выбор визуального оформления для состояния «Ожидание»
Num1 | Выбор визуального оформления для состояния «Наведение»
Num2 | Выбор визуального оформления для состояния «Нажатие»
Home | Активация списка выбора визуального шаблона из библиотеки
Insert | Добавляет активный шаблон в библиотеку
Page Up | Для постепенного перемещения к началу библиотеки визуальных шаблонов
Page Down | Перемещения к концу библиотеки визуальных шаблонов
F2 | Открытие\закрытие вкладки «Шаблоны кнопок»
F4 | Вызов диалога выбора цвета для первого цвета градиента
F5 | Вызов диалога выбора цвета для второго цвета градиента
F6 | Вызов диалога выбора цвета для цвета за границами не прямоугольной кнопки
F7 | Вызов диалога выбора цвета для тени текста
F8 | Вызов диалога выбора цвета для бордюра (границы) кнопки
F9 | Вызов диалога выбора цвета для цвета текста
F10 | Вызов диалога выбора стиля градиента (заливки)
F11 | Вызов диалога выбора шрифта
F2 | Открытие\закрытие вкладки «Шаблоны»
При открытой вкладке «Новая кнопка (F5)»
F8 | Переход к строке с именем кнопки
F9 | Переход к списку клавиш для формирования результирующей строки
F7 | Вызов диалога выбора файла
F6 | Создает новую кнопку
F5 | Открытие\закрытие вкладки «Новая кнопка»


Технический раздел.

Он может пригодиться, если Вам интересно, что находиться в корневой папке вместе с приложением.

Перечислю файлы, которые должны быть с приложением:

Имя файла | Описание
Ani2.gif | Заставка программы с авторскими данными и рисунком улитки.
BiblotekForm.ini | Содержит визуальные шаблоны форм для Конструктора
BiblotekKnopokList.ini | Содержит визуальные шаблоны кнопок для Конструктора
Char.xen | Символы для Английской раскладки клавиатуры с соответствующими кодами клавиш
Char.xru | Символы для Русской раскладки клавиатуры с соответствующими кодами клавиш
Config.ini | Сохраняет основные параметры для запуска программы
Vk.ini | Остальные клавиши стандартной клавиатуры и их коды

Еще в корневом каталоге содержится папка «Virtual»,которая содержит все доступные виртуальные клавиатуры и их рисунки.

Каждая виртуальная клавиатура состоит от одного до трёх файлов.

Имена файлов, в которых, хранятся виртуальные клавиатуры, задаются по следующей схеме:

Имя файла | Примечания
[n..n].ini где [n..n] – имя виртуальной клавиатуры даётся в конструкторе и при ее создании | Основной файл содержит, описание кнопок для стандартной клавиатуры формируется из файлов; char.xen; char.xru; vk.ini
[n..n]Plus.ini | Содержит кнопки, которые создаются в конструкторе
[n..n]screen.bmp | Скриншот-рисунок клавиатуры,он создается в момент ее сохранения в Конструкторе.И отображается в окне настроек программы.

Из выше сказанного следует, что распространение виртуальных клавиатур не составить труда, нужно всего лишь скопировать названные выше файлы в папку «Virtual» и открыть окно настройки программы, для выбора вновь помещенной клавиатуры.


Благодарность

Я бы не смог написать эту программу и справку без поддержки и технической помощи своего друга, Бочкова Владимира Юрьевича.

Уважаемый Владимир Юрьевич!

Позвольте выразить Вам искреннюю благодарность за, бесчисленное число проделанных тестов программы, а также за многократные советы в стремлении к идеалу.

Д. Поляков.


Наши Контакты

Наверх Предыдущая

Вы сможете задать любой вопрос по нашей программе зайдя по этой ссылке на наш сайт. Быстрый Набор

Ждем ваших пожеланий,идей и советов! А самое главное конструктивной критики!
Наш Email Быстрый Набор

С уважением.

Д.Поляков и В.Бочков