Информация

Программа "БЫСТРЫЙ Набор 3"

 Наверх Следующая

Программа является логическим продолжением программ БН 1 и БН 2 компании Web-студия Минерва.

Основные возможности программы:

1. Работа практически с любым приложение операционной системы Windows Vista и ниже.

2. Возможность пополнения словаря как прямым редактированием *.txt файла словаря, так и с помощью горячей клавиши во время показа специальной подсказки.

3. Интеллектуальная работа со знаками препинания.

4. Также включена звуковая клавиатура которая пригодиться людям со слабым зрение.

5. В дополнение в состав программы включена настраиваемая панель для запуска четырёх необходимых Вам программ.


Сайт проекта

Наверх Предыдущая Следующая

Сайт проекта БН www.bnabor.minervastudio.ru

Ведущий программист проекта Поляков Дмитрий Владимирович почта almaz-vil@mail.kamchatka.ru


Благодарности

За идею этой программы:

Владимиру Бочкову.

За связь между автором идеи и мною:

Пузанову Александру.

И всем сотрудникам Web-студия Минерва.


Руководство пользователя

Краткое знакомство с проектом "БН".

Программа “Быстрый набор” создаётся для людей с ограниченными возможностями. А также для тех у кого нет времени на обучение скоростному набору текста. Работает по тому же принципу что и поисковые системы. По мере того как человек набирает букву, тут же выпадает меню со списком всех слов, начинающих на эту букву. Остается только выбрать слово и печатать дальше.

В программе БН 2 и БН 1 есть два словаря: Русский и Английский. Имеется возможность добавлять неограниченное количество словарей, добавлять свои слова в словарь, автоматически сохранять документ, настраивать горячие клавиши, интеллектуальная работа со знаками препинания. В состав БН 2 включены две клавиатуры — звуковая и виртуальная. Программа “Быстрый набор” проста в использовании. С ней могут работать как взрослые, так и дети. Работа программы проверенна в системе XP SP2 и Vista.

На данный момент БН 3 является не отдельным приложением, а дополнением к текстовым приложениям операционной системе. На данный момент имеет в своем составе звуковую клавиатуру и настраиваемую панель быстрого запуска.


Знакомство с БН 3

Наша программа старается облегчит общение с компьютером людям с ограничеными возможностями. А люди которые испытывают трудности с великим русским языков, могут использовать данную программу как орфографический словарь.

Рассмотрим принцип работы программы

1. После запуска программы в области рядом с часами появляется значок БН 3. Вид до запуска [image] и вид области уведомления после запуска [image] .

2. Программа может работат в режиме словаря, в режиме звуковая клавиатура и совместно сразу в двух режимах.

3. Выбирать необходимый режим можно как с помощью контекстного меню значка [image], с помощью горячих клавиш, а также с помощью специального меню которое вызывается следующим образом. В режиме словаря перейдя к выбору слова нажмите клавишу <ALT> или <Home> и работайте с строкой меню [image]. Таким образом из работы с нашей программой можно исключить компьютерную мышь.

4. Работа в режиме словаря практически аналогична работе программ БН 1 и БН 2 за исключениям того, что программа работает практически в любом приложение Win XP .

Для включения режима словаря. Нажмите клавишу <F8> данная клавиша определена по умолчанию! При включенном режиме, после начала ввода текста появляется список из 7 слов. (см. рис. )

Для перехода к словарю. Нажмите клавишу <DOWN> - курсорная клавиша вниз. С помощью курсорных клавиш выделите нужное слово.

И нажмите клавишу <ENTER>, программа вставляет выделенное вами слово и добавляет пробел после него. При этом список слов исчезает.

Особым образом также происходит реакция на различные знаки препинания.
На данный момент программа разделяет знаки препинания на пять групп:

В первую группу входят следующие знаки: (.!?)- программа автоматически ставит пробел после соответствующего знаков, делает заглавной введенную за ними букву, и при наличие до знака пробела удаляет соответствующей пробел.

Вторая группа - (,:;) - после знака добавляется пробел, и при наличие до знака пробела удаляет соответствующей пробел.

Третья группа - ( - + = ) - после знака добавляется пробел, до знака также добавляется пробел при его отсутствии.

Четвертая группа - ( { [ ( <) - после знака пробел удаляется, а до знака добавляется пробел при его отсутствии.

Пятая группа - (>}]) - после знака добавляется пробел, а до знака удаляется.

При необходимости добавит новое для программы слово в словарь, можно при появление специальной подсказки нажмите клавишу <F5>. По умолчанию назначена именно она.

Особо следует рассмотреть работу с горячими клавишами программы, так как они перекрывают работу горячих клавиш остальных приложений. Следует особо отметит тот факт, что в настройках БН 3 возможно изменит практически любую горячую клавишу.

По умолчанию я выбрал следующие горячие клавиши: Рассмотрим их подробнее.

Клавиша <F5> активизируется при появление специальной подсказки [image] и с исчезновением данной подсказки клавиша прекращает своё действие.

Клавиша <стрелка вниз> активизируется при появлении списка слов и со скрытием данного прекращает своё действие.

Клавиша <ESC> активизукется после перехода к словарю и следовательно прекращает свое действие при сокрытие списка слов.

Клавиша <F4> активизируется при запуске программы и прекращает своё при выходе из БН 3. Служит для активизации и деактивации остальных горячих клавиш, что минимизирует возможность конфликта с горячеми клавишами другого приложения.

После активации клавиша <F8> включает или выключает режим словаря, клавиша <F2> включает или выключает режим звуковой клавиатуры, и клавиша <Page Down> включает или выключает отображение панели быстрого запуска. Настройка панели осуществляется в настройках программы.

После активации клавиша <F9> служит для выхода из приложения "БЫСТРЫЙ Набор 3".

В техническом разделе будет рассмотрена настройка программы.


Технический раздел

На странице "Настройка" рассмотрены принципы изменения внешнего облика списка слов. Подбор приложений для запуска через Панель БН 3. И возможность выбора горячих клавиш.

На странице "Файлы БН 3" приводятся некоторые сведения о внутреннем строении программы.


Настройка

По команде контекстного меню программы "Настройка" появиться окно:

На вкладке "Визуальное оформление" можно подобрать необходимый Вам цвет фона списка, цвет и размер шрифта слов в списке. По умолчанию выбран шрифт " New Roman" при желании его можно изменить прямым редактированием файла configP.ini структура которого рассмотрена в разделе "Файлы БН 3".

На вкладке "Панель управления" можно изменить надпись на кнопке и выбрать файл который будет запускаться по щелчку на соответствующей кнопке.

При желание возможно отредактировать файл configPanel.ini отметим, что запускаются только программные файлы, то есть с расширением *.exe.

На вкладке "Горячии клавиши" возможно подобрать удобную для Вас клавишу клавиатуры для каждой из предложенных операций.

ВНИМАНИЕ!!! Выбор одной клавиши для более чем одной операции приведёт к неработоспособности программы БН 3!!!
Путём прямого редактирования файла vk.ini можно увеличит число предлагаемых клавиатурных клавиш. А в файле configP.ini произвести ручной ввод горячий клавиши для каждой операции..


Файлы БН 3

После работы установочного файла программы. В папке БН 3 Вы найдёте в том числе следующие файлы.

1. Файл configP.ini который содержит основные параметры программы.
Рассмотрим его структуру:
[Color] // цвет в цифровой форме

Fon=65535 // для фона в списке слов

Text=8 // и для текста соответственно

[Font] // параметры для шрифта в списке слов

FontName=Times New Roman // имя шрифта

FontSize=22 // размер шрифта

[Flagi] // режимы работы программы 0 - выключен 1 - включен

SoundKLAVA=0 // звуковая клавиатура (выключена)

Panel=0 // панель (выключена)

flagClovar=1 // словарь (включен)

[Position_Panel] // позиция панели в экранных координатах

Top=30 // по Y

Left=262 // по Х

[TekGoriachiiKlavishi] // определение текущих горячих клавиш значения определённы в файл vk.ini (смтр. ниже)

VKAddClovo=116 . // добавить новое слово

VKInClovar=40 // перейти к выбору слов

VKNotClovar=27 // выйти из словаря и отказаться от выбора слова

VKClovo=13 // подтвердит выбор слова

VKOnOffClovar=119 // включить/выключить словарь

VKOnOffSoundKlava=113 // включить/выключить звуковая клавиатура

VKOnOffVk=115 // включить/выключить горячии клавиши

VKOnOffPanel=34 // включить/выключить панель

VKOffBN3=120 // выключить программу.

2. Файл vk.ini который содержит список виртуальных клавиш. При желание может дополняться формат строк [наименование клавиши]=[её код]

Текущее содержание файла:

ENTER=13

Стрелка вверх=38

Стрелка вниз=40

Стрелка вправо=39

Стрелка влево=37

Home=36

End=35

Page Down=34

Page Up=33

ESC=27

F1=112

F2=113

F3=114

F4=115

F5=116

F6=117

F7=118

F8=119

F9=120

F10=121

F11=122

F12=123

3. Файл configPanel.ini который содержит параметры для Панели БН 3.

Структура файла:

[ButtonRUN]

CaptionB1=Быстрый набор //надпись соответствующей кнопки

RUNB1=Bn2.exe // полный путь к запускаемому файлу

CaptionB2=Виртуальные клавиши

RUNB2=

CaptionB3=Говорящие клавиши

RUNB3=

CaptionB4=MS Word

RUNB4=C:\Program Files\Microsoft Office\Office10\WINWORD.EXE

Для работы звуковой клавиатуры необходима папка "ЗВУКИ" содержавшия wav файлы.

В папки "СЛОВАРИ" содержится обычный текстовой файл со списком слов и файл config.ini он аналогичен файлу из БН 1 и БН 2.
Его структура:

0|RUS|словари\RUS.txt|1| - где RUS.txt - Имя файла со списком слов, остальные параметры оставленны для совместимости с БН 1 и БН 2.


К пользователю.

Наверх Предыдущая

• Наша программа БЫСТРЫЙ Набор 3, является условно-бесплатной (donation-ware).

• Это означает, что пользоваться ей можно свободно, а оплата производится по Вашему желанию.

• Если вам понравилось то, что мы делаем, можете поддержать нашу веб-студию "Минерва" материально. Для дальнейшего - развития как в сфере разработки ПО, так и в сфере веб-дизайна.

• Номера кошельков:

o WebMoney R417741626731 (рубли)

o WebMoney Z380009977002 (доллары)

o Яндекс.Деньги 4100157784099

• Если Вам удобен другой способ оплаты – свяжитесь с нами по адресу: a.s.puzanov@gmail.com

• Спасибо!

• И отдельное спасибо уже приславшим деньги!