Информация

Navigation: »No topics above this level«

Программа "Быстрый Набор" v2

 Return to chapter overview

Основные возможности:

· Ввод текста из словарей.
· Неограниченное количество словарей.
· Возможность оперативно добавлять текущее слово в словарь.
· Возможность включения режима автосохранения документа.
· Включение/выключения режима словаря.
· Выбор словаря по умолчанию.
· Настройка горячих клавиш.
· Звуковая клавиатура
· Виртуальная клавиатура


Благодарности

Navigation: Информация >

Благодарности

 Return to chapter overview

За идею этой программы:

Владимиру Бочкову.

За связь между автором идеи и мною:

Пузанову Александру.


Разработчик

Navigation: Информация >

Разработчик

 Return to chapter overview

Поляков Дмитрий Владимирович.

При участии фирмы Minevra Web-Studio

По всем вопрос обращаться: almaz-vil@mail.kamchatka.ru


Руководство пользователя

Navigation: »No topics above this level«

Руководство пользователя

 Return to chapter overview

После запуска программы должно появится главное окно (см. рисунок.).

Главное окно программы:

В освоении программы поможет: панель управления и строка состояния.

1. Панель управления:

Команды панели управления(слева на право ):

-вырезать,

-вставить,

-копировать,

-выделить всё,

-новый документ,

-открыть,

-сохранить,

-сохранить как...,

-печать,
-включить звуковую клавиатуру,

-выключить звуковую клавиатуру,

-включить виртуальную клавиатуру,
-выключить виртуальную клавиатуру,

-включить словарь,

-выключить словарь,

-параметры программы,

-редактор словарей,

-вызов справки,

выход.

2. Строка состояния:

-отображаться состояние словаря(вкл/выкл),

-подсказка для включения словаря или сведенья о включенном словаре.

-состояние режима автосохранения (для включения обратись к настройкам программы).


Overview

Navigation: Руководство пользователя >

Начало работы.

 Return to chapter overview

Если в процессе загрузки программы возникла ошибка, прочитайте раздел "Ошибки".

При успешном запуске появиться окно.

1.Включена виртуальная клавиатура.

Программа начинает работу в выключенном режиме словаря. Для включения режима словаря. Нажмите клавишу <F8> данная клавиша определена по умолчанию!

2. Виртуальная клавиатура выключена.

При включенном режиме, после начала ввода текста появляется список из 7 слов. (см. рис. )

Для перехода к словарю. Нажмите клавишу <DOWN> - курсорная клавиша вниз. С помощью курсорных клавиш выделите нужное слово.

И нажмите клавишу <ENTER>, программа вставляет выделенное вами слово и добавляет пробел после него. При этом словарь исчезает.

Таким образом возможно редактировать ранее введенный текст.

Особым образом также происходит реакция на различные знаки препинания.
На данный момент программа разделяет знаки препинания на пять групп:

В первую группу входят следующие знаки: (.!?)- программа автоматически ставит пробел после соответствующего знаков, делает заглавной введенную за ними букву, и при наличие до знака пробела удаляет соответствующей пробел.

Вторая группа - (,:;) - после знака добавляется пробел, и при наличие до знака пробела удаляет соответствующей пробел.

Третья группа - ( - + = ) - после знака добавляется пробел, до знака также добавляется пробел при его отсутствии.

Четвертая группа - ( { [ ( <) - после знака пробел удаляется, а до знака добавляется пробел при его отсутствии.

Пятая группа - (>}]) - после знака добавляется пробел, а до знака удаляется.

При необходимости добавит новое для программы слово в текущий словарь-просто нажмите клавишу <F5>. По умолчанию назначена именно она.

Количество словарей подключенных к программе бесконечно.Переключится между ними можно с помощью команд подменю Сервис - Словари.

Изучив раздел "настройки" вы узнаете как установить по умолчанию свои параметры шрифта для текстового поля и для словарного поля, как включить/выключить авто сохранение документа, включить/выключить режим словаря после запуска программы. А также вы сможете изменить горячие клавиши.

Для перехода к настройкам нажмите <F9>. А к редактору словарей можно обратится нажав <F6>.

Также заглянув в раздел словари вы узнаете каким образом добавить или удалить словари из программы.

По всем вопросам обращайтесь к разработчику.


Настройки

Настройки

Выберите в строке меню Сервис - Параметры. Откроется окно.

Окно содержит три вкладки "При загрузке", "Общие" и "Горячие клавиши".

На вкладке "Общее" можно включить/выключить режим автосохранения текущего документа и соответственно задать период его сохранения.

В разделе "действия" можно добавлять свои знаки препинания.

На вкладке "При загрузке" можно:

1.включить/выключить режим словаря.

2.включить/выключить звуковую клавиатуру.

3.включить/выключить виртуальную клавиатуру .

Установить параметры шрифта для текста и списка словаря соответствующими кнопками.

На вкладке "Горячие клавиши" можно изменить соответствующие сочетания клавиш. Соответственно выбрав нужную клавишу из списка. Есть возможность добавлять и новые клавиши в списки путем редактирования служебных файлов.

Стандартное поведение программы можно восстановить следующим образом.

1.Нажать кнопку "Настройки по умолчанию".

2.Перезапустить программу.

Или же:

1.Удалить из рабочей папки программы файл configP.ini

2.Запустить программу.


Словари

Словари

Выберите в строке меню Сервис - Редактор словарей. Откроется окно.

Чтобы программа могла работать со словарем необходимо его добавить с помощью кнопки "Добавить". Словарь-это файл с расширением *.txt, [image] который содержит слова и словосочетания каждое из которых записано с новой строки.

После открытия соответствующего файла появляется диалог задания имени словаря.

для удобства укажите своё имя

Именно так в дальнейшем этот словарь и будет отображаться в программе.

Галочкой следует отметит словарь который будет загружаться по умолчанию.

В меню Сервис - Словари текущий словарь отмечается галочкой. Ставить сразу две галочки не рекомендуется.

Если Вы не выбрали ни одного словаря программа выдаёт предупреждение

В дальнейшем в меню Сервис - Словари можно будет выбрать словарь. Он же и будет считаться словарем по умолчанию при повторном запуске.

Добавить новые слова можно во время ввода текста с помощью соответствующей клавиши.При этом во время выхода или изменения текущего словаря изменения сохраняются. Так же изменить словарь можно в Редакторе словарей с помощью соответствующих кнопок.

Для этого выделяем необходимый словарь [image] при этом словарь загружается
введя новое слово длиной не менее 1 символа, появляется возможность добавить его в словарь [image] [image] так, как слово "большой" уже находилось в словаре оно не добавилось, а лишь отобразилось. А вот после добавления слова "Автомобиль" активизировалась кнопка сохранения. можно продолжать добавлять слова, при этом на панели состояния отображается: общее число слов и число не сохраненных слов [image] после сохранения изменений надпись на панели состояния тоже изменяется [image] .

В свою очередь можно также заменить слово предварительно выделив его и выделенное слово заменяется.

Так как словари это текстовые файлы,то редактировать их можно в любом редакторе.


Ошибки

Ошибки

1.Удалите файл configP.ini и перезапустите приложение.

2.При ошибке об отсутствие словарей добавте их. подробнее

3. Удалите файл config.ini из папки Словари и повторите п.2.

4. Переустановите программу.

5. Обратитесь к разработчику.